Go Back   Jeep Liberty Forum - JeepKJ Country > Jeep Liberty - KJ (02 to 07) > KJ General Discussion

Register to remove these ads.



KJ General Discussion

Error Code P0430 Catalyst Efficiency


This is a discussion on Error Code P0430 Catalyst Efficiency within the KJ General Discussion forums, part of the Jeep Liberty - KJ (02 to 07) category!
Register to remove these ads. It's free! Hello all. I've owned my 05 Liberty for about 6 months now and ...

General discussion forum for KJ Liberty's


Reply
 
LinkBack Thread Tools Display Modes
Old 11-21-2008, 12:51 PM   #1 (permalink)
Member

 
Join Date: Aug 2008
Location: SW Missouri
Posts: 2
Default Error Code P0430 Catalyst Efficiency


Register to remove these ads. It's free!
Hello all. I've owned my 05 Liberty for about 6 months now and am now getting a check engine light. The error code is P0430.

AutoZone printed this off for me:
The PCM has determined that the catalyst system efficiency for bank 2 is below threshold for the current engine operating condisitons. (Bank 1 identifes the location of cylinder #1, while bank 2 identifies the cylinders on the opposite bank)

Since purchasing my Liberty i've added a Flowmaster 50 Series muffler and a K&N airfilter. Do you think this would cause this error or have any ideas what else would cause this error? Thanks for your help.
jeremyc is offline   Reply With Quote
Old 11-21-2008, 02:44 PM   #2 (permalink)
 
long_tall_texan's Avatar
Member

 
Join Date: Oct 2008
Location: DFW, TX
Posts: 433
Default

I actually had the exact same code a few months back on my wife's suburban. Turns out the catalytic converter went bad. Reach under your KJ and tap on the cat with a rubber mallet. If you hear any rattling from inside the cat, then it needs to be replaced. Not sure about the Jeep warranty, but my suburban had an 8 year / 80,000 mile warranty for the cat, so they replaced it at no charge. I had 78,800 on it - Just in time.
__________________
2007 Light Khaki 4x2 Sport
- Debadged - LTT CAI with Amsoil Filter - JVC HD Radio - Infinity BassLink
- Iggee Seat Covers - Black Moabs - 265/75-16 Cooper Discoverer ATP
- DIY Franky sitting at 23.75" - Al's 4.5 UCAs - Trimmed F&R Bumpers
- Removed Rear Sway Bar - Removed Rear Vibration Damper
- 72k miles so far...
long_tall_texan is offline   Reply With Quote
Old 11-23-2008, 04:45 PM   #3 (permalink)
Member

 
Join Date: Nov 2008
Location: WV
Posts: 2
Send a message via AIM to D-Rod
Default

I had this same code when i first purchased my liberty back in May, it actually came on as i was pulling into my driveway. I took it back to the dealer and they said the catalytic converter was bad. It was still obviously under warrenty. They changed it out and i havent had a problem with that since.
D-Rod is offline   Reply With Quote
Old 11-23-2008, 08:27 PM   #4 (permalink)
 
JeepJeepster's Avatar
Member

 
Join Date: Dec 2004
Location: Dem hollers in Ky
Posts: 8,352
Default

No, those would not cause any problems.

Pretty sure the kj has the same warranty when it comes to the cats. I think thats a pre-set warranty for all vehicles.
__________________
-2004 Jeep Liberty Limited
-Atlantic Blue
-Transfer Case: NP242
-OME/Rustys Lift
-Powertrax No-slip
-Flowmaster 50 Series SUV
-245/70/16 Yokohama Geolander A/T-S's on MOABS
Jeepsters Gallery
JeepJeepster is offline   Reply With Quote
Old 11-23-2008, 09:09 PM   #5 (permalink)
 
Dave's Avatar
Administrator


 
Join Date: Feb 2006
Location: on here
Posts: 15,605
Default

Originally Posted by JeepJeepster View Post
Pretty sure the kj has the same warranty when it comes to the cats. I think thats a pre-set warranty for all vehicles.
Yes, the 8/80,000 is a federally mandated warranty for cats and applies to all vehicles sold.

Dave
__________________
05 Black KJ.....aka "The Pig".....
Lifted, Bent Rock Rail, and "Minor Organic Trail Rash".....

Need More Stuff..

Become a Supporting Member
http://www.jeepkj.com/forum/payments.php
Dave is offline   Reply With Quote
Old 09-14-2016, 11:26 AM   #6 (permalink)
Member

 
Join Date: Sep 2016
Location: Lake Winnipesaukee, NH
Age: 40
Posts: 25
Default

Bringing this back from the dead. I have the same code, the cat doesn't rattle and I have replaced both o2 sensors. Does this mean the cat is bad or is there something else I can check? Thanks guys! Damn newbies, lol.
ptulli is offline   Reply With Quote
Old 09-14-2016, 11:56 AM   #7 (permalink)
Moderator

 
Join Date: Jul 2005
Location: Central Ohio
Age: 63
Posts: 16,068
Default

Originally Posted by ptulli View Post
Bringing this back from the dead. I have the same code, the cat doesn't rattle and I have replaced both o2 sensors. Does this mean the cat is bad or is there something else I can check? Thanks guys! Damn newbies, lol.
Fill us in a little bit more, like year/ mileage?? , did you have the code cleared afterwards??,( should rest after a while but?? ) you replaced both on the right side ??
__________________
I'm just here to comfort disturbed people and disturb comfortable people.
MUDD'S MOTORSPORTS 04 Kilimanjaro Edition
Skink Super Sliders GTP Louvers/4.10s/ etc
CURRENT PROJECT 03 OVERLAND EDITION, Timberline Green Pearlcoat, 81,000 miles, one owner, JBA 2.5 inch Total Control Lift, Kilby gas tank skid, Skid Row, 4XGuard mixture, MOABs, 265-70-16s, 4.10s, Mudds rear bumper
05 Limited/stock for now
tommudd is offline   Reply With Quote
Old 09-14-2016, 12:35 PM   #8 (permalink)
Member

 
Join Date: Sep 2016
Location: Lake Winnipesaukee, NH
Age: 40
Posts: 25
Default

Originally Posted by tommudd View Post
Fill us in a little bit more, like year/ mileage?? , did you have the code cleared afterwards??,( should rest after a while but?? ) you replaced both on the right side ??
It's an 05 sport with 62k on it. I had the jeep dealer I work for do the changing of the o2 sensors, same price if i bought one at the store. They said both are now replaced, not 100% sure what that means. They did clear the code and I drove around 350 miles before it came back on.
ptulli is offline   Reply With Quote
Old 09-24-2016, 04:28 PM   #9 (permalink)
Member

 
Join Date: Sep 2016
Location: Lake Winnipesaukee, NH
Age: 40
Posts: 25
Default

Anyone? Don't really want to spend $1000 to get it fixed if there is another option.
ptulli is offline   Reply With Quote
Old 09-24-2016, 04:50 PM   #10 (permalink)
 
jeeplib05's Avatar
Supporting Member

 
Join Date: Jan 2016
Location: Ohio
Posts: 826
Default


Register to remove these ads. It's free!
I believe that was the code I had back in December
Dealer changed out the converter and it was still there
They changed the O2s and now I haven't gotten it since
Unless they put one or two faulty O2 sensors in there I would say it might be the converter unfortunately
I got lucky and got all of it replaced for free from my dealer
__________________
2005 KJ 3.7l 4x4
OME/Bilstein 3.25" Lift
AirLift1000, Bull Bar, HIDs, LED Fogs, 2 LED Light Bars
31x10.5 Goodyear Authority's on TM5s, 20% Tint, Pioneer HU, Super 44

2012 Challenger R/T Classic
Sequential Tail Light Mod, K&N 57 Series Air Intake, Stainless MOPAR Door Sills, Stainless MOPAR Pedals, LED Fogs, GTS Tinted Tail Lights, Cobra SPX 7800BT, Dual FM 40 Series with Reso Delete, 8" RF P|2, SpeedLogix OCC
jeeplib05 is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum